Windev Mise à Jour de sa base via un fichier Texte ou Ascii

Un bout de code facile à mettre en oeuvre que vous pourrez utiliser au chargement de vos programmes afin de maintenir à jour votre base de donnée via un fichier externe. A adapter avec vos propres variables. Le fichier externe dans cet exemple est formaté avec des séparateurs “;”. Le principe est de supprimer tous les enregistrements de la base de données et d’y réinscrire tous les enregistrements se trouvant dans le fichier externe ligne par ligne. fichierext est une chaine = chemin+nom de votre fichier NumFic = fOuvre(fichierext,foLecture) SI NumFic = -1 ALORS // Erreur détectée pendant l’ouverture du fichier Erreur(”Erreur d’ouverture du fichier “+ fichierext,ErreurInfo()) SINON HExécuteRequêteSQL(Req_suppression,”DELETE FROM artfus”) // Lecture ligne par ligne du fichier BOUCLE Ligne est une chaine = fLitLigne(NumFic) SI Ligne = EOT ALORS SORTIR Base.Rubrique1=ExtraitChaîne(Ligne, 1,”;”) Base.Rubrique2=ExtraitChaîne(Ligne, 2,”;”) Base.Rubrique3=ExtraitChaîne(Ligne, 3,”;”) Base.Rubrique4=ExtraitChaîne(Ligne, 4,”;”) Base.Rubrique5=ExtraitChaîne(Ligne, 5,”;”) Base.Rubrique6=ExtraitChaîne(Ligne, 6,”;”) Base.Rubrique7=ExtraitChaîne(Ligne, 7,”;”) Base.Rubrique8=ExtraitChaîne(Ligne,8,”;”) Base.Rubrique19=ExtraitChaîne(Ligne,9,”;”) HAjoute(Base) FIN // Fermeture du fichier fFerme(NumFic) FIN

Laisser une réponse